domingo, 10 de noviembre de 2013

TIPOS DE ERROR - EXCEL 2007


TIPOS DE ERROR EN EXCEL 2007

Los errores de la hoja de cálculo, a veces molestos y poco estéticos, otras veces necesarios para conocer donde estamos cometiendo un fallo de cálculo o porqué un resultado no es el esperado.

Vamos a ver unas cuantas formulas que nos ayudaran en todas estas cuestiones, como evitar que aparezca el error, o aprovecharlo dentro de la misma formula y que nos arroje otro resultado o simplemente saber el porqué y el qué lo ha producido.



Función SI.ERROR()

Esta función comprueba una operación, si puede la realiza, sino devuelve el mensaje definido por el usuario.
En el primer ejemplo la función comprueba la división, si hay un error dejará la celda en blanco.
D1=SI.ERROR(A1/B1;"")
En este ejemplo si detecta un error inserta el mensaje, Revisa el divisor.
D2=SI.ERROR(A1/B1;"Revisa el divisor")



SI.ERROR es una función muy flexible ya que si no puede realizar la operación le dejaremos una instrucción de lo que queremos que la celda muestre.

Función ESERROR()

Comprueba si un valor es un error y devuelve VERDADERO o FALSO.
Suele ir acompañada del condicional SI.

En el ejemplo devuelve VERDADERO o FALSO.
D1=ESERROR(A1/B1)
Combinado con el condicional SI devuelve un resultado definido por el usuario.
D2=SI(ESERROR(A1/B1);"Hola";"Adiós")



Función NOD()

Devuelve el valor #N/A Valor no disponible. Esta función no tiene argumentos.
La utilidad de esta función es marcar celdas para que no realicen cálculos, es lo mismo escribir en la celda =NOD() que #N/A, cualquier formula que haga referencia a una celda con este valor devolverá #N/A.



Función TIPO.DE.ERROR()

Esta función permite clasificar los errores con un número que tiene asignado a cada error.
Si el valor del error es:
VALOR DEL ERROR    DEVUELVE
#¡NULO! 1
#¡DIV/0! 2
#¡VALOR! 3
#¡REF! 4
#¿NOMBRE? 5
#¡NUM! 6
#N/A 7
#OBTENIENDO_DATOS 8
Otro valor #N/A

En este ejemplo devuelve el número de error:
D1=TIPO.DE.ERROR(A1/B1)
Al igual que alguna de las funciones vistas anteriormente, esta función suele ir acompañada del condicional SI, sacando lo mejor de la función TIPO.DE.ERROR, en el ejemplo la formula dice que si el tipo de error es igual a 2 inserte el mensaje Revisa el divisor.
D2=SI(TIPO.DE.ERROR(A1/B1)=2;"Revisa el divisor")


Errores mas frecuentes:
La intersección de dos rangos no existe #¡NULO!
No se puede dividir entre 0 #¡DIV/0!
Argumento de función equivocado #¡VALOR!
Celda invalida por estar fuera del rango de una formula #¡REF!
Se ha escrito mal la función #¿NOMBRE?
Excel espera un número o un determinado número como resultado #¡NUM!
No encuentra la coincidencia exacta en una matriz #¡N/A!